kandi background
kandi background
Explore Kits
kandi background
Explore Kits
Explore all Nodejs open source software, libraries, packages, source code, cloud functions and APIs.

Popular New Releases in Nodejs

electron v19.0.0-alpha.4

v0.26.1

2022-04-19, Version 18.0.0 (Current), @BethGriggs

v12.1.6-canary.6

TypeScript 4.7 Beta

electron

electron v19.0.0-alpha.4

axios

v0.26.1

node

2022-04-19, Version 18.0.0 (Current), @BethGriggs

next.js

v12.1.6-canary.6

TypeScript

TypeScript 4.7 Beta

Popular Libraries in Nodejs

Trending New libraries in Nodejs

Top Authors in Nodejs

1

398 Libraries

123945

2

383 Libraries

10414

3

279 Libraries

6750

4

249 Libraries

3144

5

174 Libraries

144734

6

152 Libraries

4920

7

150 Libraries

19486

8

136 Libraries

34291

9

119 Libraries

33103

10

116 Libraries

2869

1

398 Libraries

123945

2

383 Libraries

10414

3

279 Libraries

6750

4

249 Libraries

3144

5

174 Libraries

144734

6

152 Libraries

4920

7

150 Libraries

19486

8

136 Libraries

34291

9

119 Libraries

33103

10

116 Libraries

2869

Trending Kits in Nodejs

No Trending Kits are available at this moment for Nodejs

Trending Discussions on Nodejs

    nodejs-16 dependency issue with libuv
    Getting Error on installing Truffle on windows 10 using npm install truffle -g
    Uncaught ReferenceError: Buffer is not defined
    Apache reverse proxy to Node - Connection refused: AH00957
    Alexa - How to send image to user?
    Fresh NextJS App throwing errors before any changes
    How to fix this node-sass build error on Netlify?
    Trying to execute "npx typescript --init" "npm ERR! could not determine executable to run"
    Discord Api Valid intents must be provided for the Client
    Bundler::GemNotFound: Could not find mimemagic-0.3.5 in any of the sources on Rails project with Docker

QUESTION

nodejs-16 dependency issue with libuv

Asked 2022-Mar-23 at 17:38

This is what I'm getting on my Amazon Linux 2 instance while trying to run yum update.

Do you suggest I use --skip-broken or wait until AWS rolls out a fix?

1--> Processing Dependency: libuv >= 1:1.42.0 for package: 1:nodejs-16.13.2-8.el7.x86_64
2--> Finished Dependency Resolution
3Error: Package: 1:nodejs-16.13.2-8.el7.x86_64 (epel-testing)
4           Requires: libuv >= 1:1.42.0
5           Installed: 1:libuv-1.39.0-1.amzn2.x86_64 (@amzn2-core)
6               libuv = 1:1.39.0-1.amzn2
7           Available: 1:libuv-1.23.2-1.amzn2.0.2.i686 (amzn2-core)
8               libuv = 1:1.23.2-1.amzn2.0.2
9 You could try using --skip-broken to work around the problem
10 You could try running: rpm -Va --nofiles --nodigest
11

ANSWER

Answered 2022-Feb-09 at 19:06

Yeah, plus 1 to this issue. OP, the --skip-broken flag will only temporarily fix your currently running servers though. If you're baking any new AMIs or spinning up any new EC2s with Terraform, CDK, etc, that --skip-broken flag won't work as its not available as part of the aws cloud.init script. This will cause any new AMI or EC2 creations to timeout and fail.

One potential work around is to try compiling libuv directly from source as > 1.39 sadly isn't currently available from any linux distro.

Source https://stackoverflow.com/questions/71043534

Community Discussions contain sources that include Stack Exchange Network

    nodejs-16 dependency issue with libuv
    Getting Error on installing Truffle on windows 10 using npm install truffle -g
    Uncaught ReferenceError: Buffer is not defined
    Apache reverse proxy to Node - Connection refused: AH00957
    Alexa - How to send image to user?
    Fresh NextJS App throwing errors before any changes
    How to fix this node-sass build error on Netlify?
    Trying to execute "npx typescript --init" "npm ERR! could not determine executable to run"
    Discord Api Valid intents must be provided for the Client
    Bundler::GemNotFound: Could not find mimemagic-0.3.5 in any of the sources on Rails project with Docker

QUESTION

nodejs-16 dependency issue with libuv

Asked 2022-Mar-23 at 17:38

This is what I'm getting on my Amazon Linux 2 instance while trying to run yum update.

Do you suggest I use --skip-broken or wait until AWS rolls out a fix?

1--> Processing Dependency: libuv >= 1:1.42.0 for package: 1:nodejs-16.13.2-8.el7.x86_64
2--> Finished Dependency Resolution
3Error: Package: 1:nodejs-16.13.2-8.el7.x86_64 (epel-testing)
4           Requires: libuv >= 1:1.42.0
5           Installed: 1:libuv-1.39.0-1.amzn2.x86_64 (@amzn2-core)
6               libuv = 1:1.39.0-1.amzn2
7           Available: 1:libuv-1.23.2-1.amzn2.0.2.i686 (amzn2-core)
8               libuv = 1:1.23.2-1.amzn2.0.2
9 You could try using --skip-broken to work around the problem
10 You could try running: rpm -Va --nofiles --nodigest
11

ANSWER

Answered 2022-Feb-09 at 19:06

Yeah, plus 1 to this issue. OP, the --skip-broken flag will only temporarily fix your currently running servers though. If you're baking any new AMIs or spinning up any new EC2s with Terraform, CDK, etc, that --skip-broken flag won't work as its not available as part of the aws cloud.init script. This will cause any new AMI or EC2 creations to timeout and fail.

One potential work around is to try compiling libuv directly from source as > 1.39 sadly isn't currently available from any linux distro.

Source https://stackoverflow.com/questions/71043534