kandi background
Explore Kits

vtm-android | Development moved to https : //github.com/opensciencemap/vtm

 by   opensciencemap Java Version: Current License: LGPL-3.0

 by   opensciencemap Java Version: Current License: LGPL-3.0

Download this library from

kandi X-RAY | vtm-android Summary

vtm-android is a Java library. vtm-android has no bugs, it has no vulnerabilities, it has a Weak Copyleft License and it has low support. However vtm-android build file is not available. You can download it from GitHub.
Development moved to https://github.com/opensciencemap/vtm. VectorTileMap is part of the OpenScienceMap project, developed at University of Bremen. http://www.opensciencemap.org. To build the eclipse project the android ndk plugin is required.
Support
Support
Quality
Quality
Security
Security
License
License
Reuse
Reuse

kandi-support Support

  • vtm-android has a low active ecosystem.
  • It has 17 star(s) with 19 fork(s). There are 10 watchers for this library.
  • It had no major release in the last 12 months.
  • There are 3 open issues and 3 have been closed. On average issues are closed in 42 days. There are no pull requests.
  • It has a neutral sentiment in the developer community.
  • The latest version of vtm-android is current.
vtm-android Support
Best in #Java
Average in #Java
vtm-android Support
Best in #Java
Average in #Java

quality kandi Quality

  • vtm-android has 0 bugs and 0 code smells.
vtm-android Quality
Best in #Java
Average in #Java
vtm-android Quality
Best in #Java
Average in #Java

securitySecurity

  • vtm-android has no vulnerabilities reported, and its dependent libraries have no vulnerabilities reported.
  • vtm-android code analysis shows 0 unresolved vulnerabilities.
  • There are 0 security hotspots that need review.
vtm-android Security
Best in #Java
Average in #Java
vtm-android Security
Best in #Java
Average in #Java

license License

  • vtm-android is licensed under the LGPL-3.0 License. This license is Weak Copyleft.
  • Weak Copyleft licenses have some restrictions, but you can use them in commercial projects.
vtm-android License
Best in #Java
Average in #Java
vtm-android License
Best in #Java
Average in #Java

buildReuse

  • vtm-android releases are not available. You will need to build from source code and install.
  • vtm-android has no build file. You will be need to create the build yourself to build the component from source.
  • vtm-android saves you 12594 person hours of effort in developing the same functionality from scratch.
  • It has 25365 lines of code, 1421 functions and 207 files.
  • It has medium code complexity. Code complexity directly impacts maintainability of the code.
vtm-android Reuse
Best in #Java
Average in #Java
vtm-android Reuse
Best in #Java
Average in #Java
Top functions reviewed by kandi - BETA

kandi has reviewed vtm-android and discovered the below as its top functions. This is intended to give you an instant insight into vtm-android implemented functionality, and help decide if they suit your requirements.

  • Updates if the labels have changed .
    • Process the number of Ways in the tile
      • Renders a piece of text .
        • Process an XML start element .
          • Draws an outline
            • Decodes the coordinates of a feature .
              • Render the extrusion layer .
                • Returns the list of RenderInstruction objects that match the given element .
                  • Handles an action move .
                    • Compiles the tile layer .

                      Get all kandi verified functions for this library.

                      Get all kandi verified functions for this library.

                      vtm-android Key Features

                      Development moved to https://github.com/opensciencemap/vtm

                      Gradle sync failed in android studio 3.6

                      copy iconCopydownload iconDownload
                      apply plugin: 'com.android.application'
                      
                          android {
                              compileSdkVersion 25
                              buildToolsVersion "25.0.2"
                      
                              defaultConfig {
                                  applicationId "com.graphhopper.android"
                                  minSdkVersion 10
                                  targetSdkVersion 22
                              }
                      
                              buildTypes {
                                  release {
                                      minifyEnabled false
                                      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                                  }
                              }
                      
                              lintOptions {
                      
                                  disable 'InvalidPackage'
                              }
                          }
                      
                      
                      
                          dependencies {
                              compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                                  exclude group: 'com.google.protobuf', module: 'protobuf-java'
                                  exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                                  exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                              }
                      
                              compile 'org.mapsforge:vtm:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                              compile 'org.mapsforge:vtm-jts:0.6.0'
                              compile 'org.mapsforge:vtm-themes:0.6.0'
                              compile 'com.caverock:androidsvg:1.2.2-beta-1'
                              compile 'com.vividsolutions:jts:1.13'
                      
                              compile 'org.slf4j:slf4j-api:1.7.21'
                              compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      // Top-level build file where you can add configuration options common to all sub-projects/modules.**
                      
                      buildscript {
                          repositories {
                              jcenter()
                              google()
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()
                              jcenter()
                              maven { url "https://oss.sonatype.org/content/groups/public/" }
                          }
                      }
                      
                      #Mon Feb 10 21:12:29 YEKT 2020
                      distributionBase=GRADLE_USER_HOME
                      distributionPath=wrapper/dists
                      zipStoreBase=GRADLE_USER_HOME
                      zipStorePath=wrapper/dists
                      distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip
                      
                      
                      
                      apply plugin: 'com.android.application'
                      
                          android {
                              compileSdkVersion 25
                              buildToolsVersion "25.0.2"
                      
                              defaultConfig {
                                  applicationId "com.graphhopper.android"
                                  minSdkVersion 10
                                  targetSdkVersion 22
                              }
                      
                              buildTypes {
                                  release {
                                      minifyEnabled false
                                      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                                  }
                              }
                      
                              lintOptions {
                      
                                  disable 'InvalidPackage'
                              }
                          }
                      
                      
                      
                          dependencies {
                              compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                                  exclude group: 'com.google.protobuf', module: 'protobuf-java'
                                  exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                                  exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                              }
                      
                              compile 'org.mapsforge:vtm:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                              compile 'org.mapsforge:vtm-jts:0.6.0'
                              compile 'org.mapsforge:vtm-themes:0.6.0'
                              compile 'com.caverock:androidsvg:1.2.2-beta-1'
                              compile 'com.vividsolutions:jts:1.13'
                      
                              compile 'org.slf4j:slf4j-api:1.7.21'
                              compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      // Top-level build file where you can add configuration options common to all sub-projects/modules.**
                      
                      buildscript {
                          repositories {
                              jcenter()
                              google()
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()
                              jcenter()
                              maven { url "https://oss.sonatype.org/content/groups/public/" }
                          }
                      }
                      
                      #Mon Feb 10 21:12:29 YEKT 2020
                      distributionBase=GRADLE_USER_HOME
                      distributionPath=wrapper/dists
                      zipStoreBase=GRADLE_USER_HOME
                      zipStorePath=wrapper/dists
                      distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip
                      
                      
                      
                      apply plugin: 'com.android.application'
                      
                          android {
                              compileSdkVersion 25
                              buildToolsVersion "25.0.2"
                      
                              defaultConfig {
                                  applicationId "com.graphhopper.android"
                                  minSdkVersion 10
                                  targetSdkVersion 22
                              }
                      
                              buildTypes {
                                  release {
                                      minifyEnabled false
                                      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                                  }
                              }
                      
                              lintOptions {
                      
                                  disable 'InvalidPackage'
                              }
                          }
                      
                      
                      
                          dependencies {
                              compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                                  exclude group: 'com.google.protobuf', module: 'protobuf-java'
                                  exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                                  exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                              }
                      
                              compile 'org.mapsforge:vtm:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                              compile 'org.mapsforge:vtm-jts:0.6.0'
                              compile 'org.mapsforge:vtm-themes:0.6.0'
                              compile 'com.caverock:androidsvg:1.2.2-beta-1'
                              compile 'com.vividsolutions:jts:1.13'
                      
                              compile 'org.slf4j:slf4j-api:1.7.21'
                              compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      // Top-level build file where you can add configuration options common to all sub-projects/modules.**
                      
                      buildscript {
                          repositories {
                              jcenter()
                              google()
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()
                              jcenter()
                              maven { url "https://oss.sonatype.org/content/groups/public/" }
                          }
                      }
                      
                      #Mon Feb 10 21:12:29 YEKT 2020
                      distributionBase=GRADLE_USER_HOME
                      distributionPath=wrapper/dists
                      zipStoreBase=GRADLE_USER_HOME
                      zipStorePath=wrapper/dists
                      distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip
                      
                      
                      
                      dependencies {
                              classpath 'com.android.tools.build:gradle:2.2.3'
                          }
                      
                      buildscript {
                          repositories {
                              google()       //add here
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()      //and here also
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                      }
                      
                      apply plugin: 'com.android.application'
                      
                      android {
                          compileSdkVersion 29
                          buildToolsVersion "25.0.3"
                      
                          defaultConfig {
                              applicationId "com.graphhopper.android"
                              minSdkVersion 16
                              targetSdkVersion 29
                          }
                      
                          buildTypes {
                              release {
                                  minifyEnabled false
                                  proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                              }
                          }
                      
                          compileOptions {
                              sourceCompatibility JavaVersion.VERSION_1_8
                              targetCompatibility JavaVersion.VERSION_1_8
                          }
                      
                          lintOptions {
                      
                              disable 'InvalidPackage'
                          }
                      }
                      
                      
                      dependencies {
                          compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                              exclude group: 'com.google.protobuf', module: 'protobuf-java'
                              exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                              exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                          }
                      
                          compile 'org.mapsforge:vtm:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                          compile 'org.mapsforge:vtm-jts:0.6.0'
                          compile 'org.mapsforge:vtm-themes:0.6.0'
                          compile 'com.caverock:androidsvg:1.2.2-beta-1'
                          compile 'com.vividsolutions:jts:1.13'
                      
                          compile 'org.slf4j:slf4j-api:1.7.21'
                          compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      
                      
                      dependencies {
                              classpath 'com.android.tools.build:gradle:2.2.3'
                          }
                      
                      buildscript {
                          repositories {
                              google()       //add here
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()      //and here also
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                      }
                      
                      apply plugin: 'com.android.application'
                      
                      android {
                          compileSdkVersion 29
                          buildToolsVersion "25.0.3"
                      
                          defaultConfig {
                              applicationId "com.graphhopper.android"
                              minSdkVersion 16
                              targetSdkVersion 29
                          }
                      
                          buildTypes {
                              release {
                                  minifyEnabled false
                                  proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                              }
                          }
                      
                          compileOptions {
                              sourceCompatibility JavaVersion.VERSION_1_8
                              targetCompatibility JavaVersion.VERSION_1_8
                          }
                      
                          lintOptions {
                      
                              disable 'InvalidPackage'
                          }
                      }
                      
                      
                      dependencies {
                          compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                              exclude group: 'com.google.protobuf', module: 'protobuf-java'
                              exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                              exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                          }
                      
                          compile 'org.mapsforge:vtm:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                          compile 'org.mapsforge:vtm-jts:0.6.0'
                          compile 'org.mapsforge:vtm-themes:0.6.0'
                          compile 'com.caverock:androidsvg:1.2.2-beta-1'
                          compile 'com.vividsolutions:jts:1.13'
                      
                          compile 'org.slf4j:slf4j-api:1.7.21'
                          compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      
                      
                      dependencies {
                              classpath 'com.android.tools.build:gradle:2.2.3'
                          }
                      
                      buildscript {
                          repositories {
                              google()       //add here
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()      //and here also
                              jcenter()
                              maven { url "https://jitpack.io" }
                      
                          }
                      }
                      
                      apply plugin: 'com.android.application'
                      
                      android {
                          compileSdkVersion 29
                          buildToolsVersion "25.0.3"
                      
                          defaultConfig {
                              applicationId "com.graphhopper.android"
                              minSdkVersion 16
                              targetSdkVersion 29
                          }
                      
                          buildTypes {
                              release {
                                  minifyEnabled false
                                  proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                              }
                          }
                      
                          compileOptions {
                              sourceCompatibility JavaVersion.VERSION_1_8
                              targetCompatibility JavaVersion.VERSION_1_8
                          }
                      
                          lintOptions {
                      
                              disable 'InvalidPackage'
                          }
                      }
                      
                      
                      dependencies {
                          compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                              exclude group: 'com.google.protobuf', module: 'protobuf-java'
                              exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                              exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                          }
                      
                          compile 'org.mapsforge:vtm:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                          compile 'org.mapsforge:vtm-jts:0.6.0'
                          compile 'org.mapsforge:vtm-themes:0.6.0'
                          compile 'com.caverock:androidsvg:1.2.2-beta-1'
                          compile 'com.vividsolutions:jts:1.13'
                      
                          compile 'org.slf4j:slf4j-api:1.7.21'
                          compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      
                      
                      

                      Community Discussions

                      Trending Discussions on vtm-android
                      • Gradle sync failed in android studio 3.6
                      Trending Discussions on vtm-android

                      QUESTION

                      Gradle sync failed in android studio 3.6

                      Asked 2020-Apr-13 at 05:23

                      Gradle sync failed: Don't know how to build models for org.gradle.tooling.internal.gradle.DefaultGradleBuild@61cdce4

                      **// Top-level build file where you can add configuration options common to all sub-projects/modules.**
                      
                      buildscript {
                          repositories {
                              jcenter()
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:2.2.3'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              jcenter()
                              maven { url "https://oss.sonatype.org/content/groups/public/" }
                          }
                      }
                      

                      build.gradle(Module:app)

                       apply plugin: 'com.android.application'
                      
                      android {
                          compileSdkVersion 25
                          buildToolsVersion "25.0.2"
                      
                          defaultConfig {
                              applicationId "com.graphhopper.android"
                              minSdkVersion 10
                              targetSdkVersion 22
                          }
                      
                          buildTypes {
                              release {
                                  minifyEnabled false
                                  proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                              }
                          }
                      
                          lintOptions {
                      
                              disable 'InvalidPackage'
                          }
                      }
                      
                      
                      
                      dependencies {
                          compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                             exclude group: 'com.google.protobuf', module: 'protobuf-java'
                             exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                             exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                          }
                      
                          compile 'org.mapsforge:vtm:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                          compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                          compile 'org.mapsforge:vtm-jts:0.6.0'
                          compile 'org.mapsforge:vtm-themes:0.6.0'
                          compile 'com.caverock:androidsvg:1.2.2-beta-1'
                          compile 'com.vividsolutions:jts:1.13'
                      
                          compile 'org.slf4j:slf4j-api:1.7.21'
                          compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      

                      I am using android studio 3.6. I am not able to build the project. I tried to invalidate caches/Restart but didn't work.

                      ANSWER

                      Answered 2020-Apr-13 at 05:23

                      Your build.gradle (Module:app) should look like this

                      apply plugin: 'com.android.application'
                      
                          android {
                              compileSdkVersion 25
                              buildToolsVersion "25.0.2"
                      
                              defaultConfig {
                                  applicationId "com.graphhopper.android"
                                  minSdkVersion 10
                                  targetSdkVersion 22
                              }
                      
                              buildTypes {
                                  release {
                                      minifyEnabled false
                                      proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
                                  }
                              }
                      
                              lintOptions {
                      
                                  disable 'InvalidPackage'
                              }
                          }
                      
                      
                      
                          dependencies {
                              compile(group: 'com.graphhopper', name: 'graphhopper-core', version: '0.9-SNAPSHOT') {
                                  exclude group: 'com.google.protobuf', module: 'protobuf-java'
                                  exclude group: 'org.openstreetmap.osmosis', module: 'osmosis-osm-binary'
                                  exclude group: 'org.apache.xmlgraphics', module: 'xmlgraphics-commons'
                              }
                      
                              compile 'org.mapsforge:vtm:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-armeabi-v7a'
                              compile 'org.mapsforge:vtm-android:0.6.0:natives-x86'
                              compile 'org.mapsforge:vtm-jts:0.6.0'
                              compile 'org.mapsforge:vtm-themes:0.6.0'
                              compile 'com.caverock:androidsvg:1.2.2-beta-1'
                              compile 'com.vividsolutions:jts:1.13'
                      
                              compile 'org.slf4j:slf4j-api:1.7.21'
                              compile 'org.slf4j:slf4j-android:1.7.21'
                      }
                      
                      

                      Your build.gradle (Module:project) should look like this

                      // Top-level build file where you can add configuration options common to all sub-projects/modules.**
                      
                      buildscript {
                          repositories {
                              jcenter()
                              google()
                          }
                          dependencies {
                              classpath 'com.android.tools.build:gradle:3.6.2'
                          }
                      }
                      
                      allprojects {
                          repositories {
                              google()
                              jcenter()
                              maven { url "https://oss.sonatype.org/content/groups/public/" }
                          }
                      }
                      

                      And your gradle-wrapper.properties should be like this

                      #Mon Feb 10 21:12:29 YEKT 2020
                      distributionBase=GRADLE_USER_HOME
                      distributionPath=wrapper/dists
                      zipStoreBase=GRADLE_USER_HOME
                      zipStorePath=wrapper/dists
                      distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip
                      
                      
                      

                      Source https://stackoverflow.com/questions/61136101

                      Community Discussions, Code Snippets contain sources that include Stack Exchange Network

                      Vulnerabilities

                      No vulnerabilities reported

                      Install vtm-android

                      You can download it from GitHub.
                      You can use vtm-android like any standard Java library. Please include the the jar files in your classpath. You can also use any IDE and you can run and debug the vtm-android component as you would do with any other Java program. Best practice is to use a build tool that supports dependency management such as Maven or Gradle. For Maven installation, please refer maven.apache.org. For Gradle installation, please refer gradle.org .

                      Support

                      For any new features, suggestions and bugs create an issue on GitHub. If you have any questions check and ask questions on community page Stack Overflow .

                      DOWNLOAD this Library from

                      Find, review, and download reusable Libraries, Code Snippets, Cloud APIs from
                      over 430 million Knowledge Items
                      Find more libraries
                      Reuse Solution Kits and Libraries Curated by Popular Use Cases
                      Explore Kits

                      Save this library and start creating your kit

                      Share this Page

                      share link
                      Consider Popular Java Libraries
                      Try Top Libraries by opensciencemap
                      Compare Java Libraries with Highest Support
                      Compare Java Libraries with Highest Quality
                      Compare Java Libraries with Highest Security
                      Compare Java Libraries with Permissive License
                      Compare Java Libraries with Highest Reuse
                      Find, review, and download reusable Libraries, Code Snippets, Cloud APIs from
                      over 430 million Knowledge Items
                      Find more libraries
                      Reuse Solution Kits and Libraries Curated by Popular Use Cases
                      Explore Kits

                      Save this library and start creating your kit

                      • © 2022 Open Weaver Inc.