code-complexity | Higher values mean hotspots | Functional Programming library
kandi X-RAY | code-complexity Summary
kandi X-RAY | code-complexity Summary
Measure the churn/complexity ratio. Higher values mean hotspots where refactorings should happen.
Support
Quality
Security
License
Reuse
Top functions reviewed by kandi - BETA
Currently covering the most popular Java, JavaScript and Python libraries. See a Sample of code-complexity
code-complexity Key Features
code-complexity Examples and Code Snippets
def record_snapshot(self):
"""Take a memory snapshot for later analysis.
`record_snapshot()` must be called once every iteration at the same
location. This is because the detection algorithm relies on the assumption
that if there is
Community Discussions
Trending Discussions on code-complexity
QUESTION
I'm quite far into the development of a game using SDL, OpenGL and C++ and am looking for ways to optimize the way the game switches between GLSL shaders for lots of different objects of different types. This is much more of a C++ question than an OpenGL question. However, I still want to provide as much context as I can, as I feel some justification is needed as to why the proposed Shader class I need, needs to be created / deleted the way that it is.
The first four sections are my justifications, journey & attempts leading up to this point, however my question can likely be answered by just the final section alone and I've intentionally written it as a bit of a tldr.
The necessity for a Shader class:I've seen many implementations online of OpenGL shaders being created, compiled and deleted all in the same function when game objects are created during gameplay. This has proven to be inefficient and far too slow in particular sections of my game. Thus, I've required a system that creates and compiles shaders during a load-time and then intermittently uses/swaps between them during game-time before being deleted later.
This has lead to the creation of a class(Shader
) that manages OpenGL shaders. Each instance of the class should manage one unique OpenGL shader each and contains some complex behavior around the shader type, where it's loaded in from, where it's used, the uniform variables it takes, etc.
With this said, the most important role of this class is to store the GLuint
variable id
that is returned from glCreateShader()
, and manage all OpenGL calls that relate to the OpenGL shader with this id
. I understand that this is effectively futile given the global nature of OpenGL(as anywhere in the program could technically call glDeleteShader()
with the matching id
and break the class), however for the purposes of intentionally encapsulating all OpenGL calls to very specific areas throughout the entire codebase this system will drastically reduce code-complexity.
The most "automatic" way to manage this GLuint id
, would be to invoke glCreateShader()
on the object's construction and glDeleteShader()
on the object's destruction. This guarantees(within OpenGL limits) that the OpenGL shader will exist for the entire lifetime of the C++ Shader object and eliminates the need to call some void createShader()
and deleteShader()
functions.
This is all well and good, however problems soon arise when considering what happens if this object is copied. What if a copy of this object is destructed? That means that glDeleteShader()
will be called and effectively break all copies of the shader object.
What about simple mistakes like accidentally invoking std::vector::push_back()
in a vector of Shaders? Various std::vector
methods can invoke the constructor / copy constructor / destructor of their type, which can result in the same problem as above.
Okay then... how about we do create some void createShader()
and deleteShader()
methods even if it's messy? Unfortunately this just defers the above problem, as once again any calls that modify the OpenGL shader will desynchronize / outright break all copies of a shader class with the same id
. I've limited the OpenGL calls to glCreateShader()
and glDeleteShader()
in this example to keep things simple, however I should note that there are many other OpenGL calls in the class that would make creating various instance/static variables that keep track of instance copies far too complicated to justify doing it this way.
The last point I want to make before jumping into the class design below is that for a project as large as a raw C++, OpenGL and SDL Game, I'd prefer if any potential OpenGL mistakes I make generate compiler errors versus graphical issues that are harder to track down. This can be reflected in the class design below.
The first version of theShader
class:
It is for the above reasons that I have elected to:
- Make the constructor
private
. - Provide a public
static create
function that returns a pointer to a new Shader object in place of a constructor. - Make the copy constructor
private
. - Make the
operator=
private
(Although this might not be necessary). - Make the destructor private.
- Put calls to
glCreateShader()
in the constructor andglDeleteShader()
in the destructor, to have OpenGL shaders exist for the lifetime of this object. - As the
create
function invokes thenew
keyword(and returns the pointer to it), the place with the outside call toShader::create()
must then invokedelete
manually (more on this in a second).
To my understanding, the first two bullet points utilize a factory pattern and will generate a compiler error should a non-pointer type of the class be attempted to be created. The third, fourth and fifth bullet points then prevent the object from being copied. The seventh bullet point then ensures that the OpenGL Shader will exist for the same lifetime of the C++ Shader object.
Smart Pointers and the main problem:The only thing I'm not a huge fan of in the above, is the new
/delete
calls. They also make the glDeleteShader()
calls in the destructor of the object feel inappropriate given the encapsulation that the class is trying to achieve. Given this, I opted to:
- change the
create
function to return astd::unique_ptr
of theShader
type instead of aShader
pointer.
The create
function then looked like this:
ANSWER
Answered 2021-Mar-04 at 08:29Implement a deleter yourself, and let the deleter be a friend of your class. Then edit your declaration like this:
QUESTION
(Hopefully) simplified version of my problem:
Say I'm using every GPIO port of my cortex M-4 mcu to do the exact same thing, like read the port on a pin-level change. I've simplified my code so it's port-agnostic, but I'm having issues with a nice solution for re-using the same interrupt handler function.
- Is there a way I can use the same interrupt handler function while having a method of finding which port triggered the interrupt? Ideally some O(1)/doesn't scale up depending on how many ports the board has.
- Should I just have different handlers for each port that call the same function that takes in a "port" parameter? (Best I could come up with so far)
So like:
...ANSWER
Answered 2020-Jul-03 at 08:51
- Is there a way I can use the same interrupt handler function while having a method of finding which port triggered the interrupt?
Only if the different interrupts are cleared in the same way and your application doesn't care which pin that triggered the interrupt. Quite unlikely use-case.
- Should I just have different handlers for each port that call the same function that takes in a "port" parameter?
Yeah that's usually what I do. You should pass on the parameters from the ISR to the function, that are unique to the specific interrupt. Important: note that the function should be inline static
! A fast ISR is significantly more important than saving a tiny bit of flash by re-using the same function. So in the machine code you'll have 4 different ISRs with the worker function inlined. (Might want to disable inlining in debug build though.)
Am I going about this all wrong and should just "keep it simple stupid"
Sounds like you are doing it right. A properly written driver should be able to handle multiple hardware peripheral instances with the same code. That being said, C programmers have a tendency to obsess about avoiding code repetition. "KISS" is often far more sound than avoiding code repetition. Avoiding repetition is of course nice, but not your top priority here.
Priorities in this case should be, most important first:
- As fast, slim interrupts as possible.
- Readable code.
- Flash size used.
- Avoiding code repetition.
QUESTION
Let's say I've the following code:
HTML:
...ANSWER
Answered 2017-Jan-04 at 11:34As you stated, there is no right or wrong. With that being said, you could e.g. use the data attribute
(jQuery data()
) for jQuery-related stuff and use classes for css styling only.
Community Discussions, Code Snippets contain sources that include Stack Exchange Network
Vulnerabilities
No vulnerabilities reported
Install code-complexity
Support
Reuse Trending Solutions
Find, review, and download reusable Libraries, Code Snippets, Cloud APIs from over 650 million Knowledge Items
Find more librariesStay Updated
Subscribe to our newsletter for trending solutions and developer bootcamps
Share this Page